0
欢迎, 游客
用户名: 密码: 记住我

主题: Debian Crashing

Debian Crashing 4 年 2 个月 前 #983

  • jgillespie
  • jgillespie的头像
  • 离线
  • Junior Member
  • 帖子: 27
  • 感谢您收到 5
  • 声望: 1
Tim,

Which GUI are you using in Debian 8.1 that is stable?
Is there a list of compatible HDMI Monitors?
What FileSystem do you recommend? EXT4?
Anything special we should do while installing , just as not using Journaling , etc?

Correct I have not found a stable stock Debian build with GUI. I have 20 boards to test with. I'm kind of at a dead end. I can't even get a stock image of Debian 8.1 with Gnome, with nothing else installed, not running any of our software to be STABLE on any board. It inconsistently crashes, sometimes I can click on Show Applications button in Debian and it will crash and restart, sometimes it wont. Maybe you have the magic hardware combo but we've tried 5 different monitors, different HDMI cable variations, different Jaguar Boards, different Debian images, different versions of Debian along with other Linux revisions, different mice, keyboards, wireless adapters. Aside from Debian I've tested Ubuntu, Puppy Linux, Fedora 22, Fedora 23, everything crashes in one way or another by simply clicking around. I've tried multiple different USB Adapters to load the OS, I've tried putting it on a CD and a DVD, I've tried 3 different external Disk Drives. Yes I can leave it running, sitting there and it wont crash but when I click around I can always find a way to make the board restart. Trying different Debian Versions now to see if that makes a difference.

What does work? Debian Server does, but once I install a GUI it always crashes. I've also tried installing a fresh Debian image with the GUI already installed as well as Debian server and manually installing the GUI, we've tested with KDE and GDE both crash.

I have also tested the memory and it never goes above using more than 400mb of RAM when using our Java file.

One thing I want to mention Tim... We still have a couple working Jaguar Boards in our factory running our software. We are scared to restart them or click away from our program because I'm sure they'll start crashing. They have been out there for nearly a month with no crash so yes in idle in definitely runs stable, but there seems to be a huge issue with opening / closing windows, even on a Debian 8.1 stock image it always eventually crashes on us. I have ordered a Debian 8 Disk instead of using the live images and then installing to see if it makes a difference.

As I type I have a JaguarBoard sitting next to me with Debian 8.1, it has been on now for about 20 hours without restarting.... I just clicked Show Applications in the Debian Menu and it crashed.

Update:
All tests done with only mouse, keyboard and network cable plugged in on a Fresh install with no additional packages on 3 different JaguarBoards. I have also tried disconnecting the HDMI cable and running ping from another computer to see if while logging in the resolution or monitor was resulting in a crash. The computer still reboots even without a monitor and only a keyboard and network cable plugged in. I have also monitores the RAM being used to confirm that it isn't filling up and crashing the computer. The RAM always stayed around only 50% usage when crashing.

Debian 8.1 with KDE Fresh Install no addons - Crashes after login and reboots. Tested with HP Monitor , Viewsonic Monitor, and 10.1" Car Monitor. Tested with HDMI -> HDMI cable, and DVI -> HDMI Cable.

Debian 8.1 with GNOME Fresh Install no addons - Crashes as GUI loads and reboots. Tested with HP Monitor , Viewsonic Monitor, and 10.1" Car Monitor. Tested with HDMI -> HDMI cable, and DVI -> HDMI Cable.

Debian 8.1 with XFCE Fresh Install no addons - Seemed stable until I opened the web browser then it crashed. Tested with HP Monitor , Viewsonic Monitor, and 10.1" Car Monitor. Tested with HDMI -> HDMI cable, and DVI -> HDMI Cable.

Debian 8.1 with LXDE Fresh Install no addons - Semi - Stable, crashed once when opening a stock program using the start menu, network connections screen froze and would not go away without a reboot. Will not recognize any USB Wifi Adapters even after apt-get install Firmware-Atheros && apt-get install Firmware-Realtek. Tested with HP Monitor , Viewsonic Monitor, and 10.1" Car Monitor. Tested with HDMI -> HDMI cable, and DVI -> HDMI Cable.

Debian 8.5 with KDE Fresh Install no addons - Crashes as GUI loads and reboots. Tested with HP Monitor , Viewsonic Monitor, and 10.1" Car Monitor. Tested with HDMI -> HDMI cable, and DVI -> HDMI Cable.

Debian 8.5 with GNOME Fresh Install no addons - Crashes as GUI loads and reboots. Tested with HP Monitor , Viewsonic Monitor, and 10.1" Car Monitor. Tested with HDMI -> HDMI cable, and DVI -> HDMI Cable.
最后修改: 4 年 2 个月 前 由 jgillespie.
本论坛禁止游客发帖。

Debian Crashing 4 年 2 个月 前 #984

  • jgillespie
  • jgillespie的头像
  • 离线
  • Junior Member
  • 帖子: 27
  • 感谢您收到 5
  • 声望: 1
Ok , so I limited the amount of memory usage by adding
vm.overcommit_memory = 2
vm.overcommit_ratio = 200

to sysctl.conf

This prevented the system from crashing.
最后修改: 4 年 2 个月 前 由 jgillespie.
本论坛禁止游客发帖。

Debian Crashing 4 年 2 个月 前 #986

  • tim
  • tim的头像
  • 离线
  • Moderator
  • 帖子: 226
  • 感谢您收到 30
  • 声望: 4
Hi Sir,

After you add the code, will it crash or not? please keep me update.
本论坛禁止游客发帖。

Debian Crashing 4 年 2 个月 前 #987

  • jgillespie
  • jgillespie的头像
  • 离线
  • Junior Member
  • 帖子: 27
  • 感谢您收到 5
  • 声望: 1
It worked yesterday now today it is still crashing. Yesterday if I opened a browser window and went to a site the browser would just crash. Today if I try it the JaguarBoard crashes. I thought I had it fixed but unfortunately it is still unusable. I also noticed that the Swap File isn't being used at all , and like I mentioned before the memory usage is never above 50%. It seems like it has to be a memory commitment issue but it's really frustrating, with 1gb Ram it should at least be usable in a lightweight GUI like XFDE.
最后修改: 4 年 2 个月 前 由 jgillespie.
本论坛禁止游客发帖。

Debian Crashing 4 年 2 个月 前 #989

  • jgillespie
  • jgillespie的头像
  • 离线
  • Junior Member
  • 帖子: 27
  • 感谢您收到 5
  • 声望: 1
Could you please have the developers look into this. I'm at a dead end with $2000 worth of JaguarBoards and cases. As I've stated even a stock Debian 8.1 install will not run smoothly. Try opening a browser with a couple tabs , more than 50% of the time it will just crash. I have Rasbperry Pi's with 1gb of Ram running the same software with no issues and have ran this software with as little as 512mb or Ram. It should run slow not crash. I refuse to believe it is a software issue when I've tried about 20 different builds, and Linux kernels and none of them are stable.
最后修改: 4 年 2 个月 前 由 jgillespie.
本论坛禁止游客发帖。

Debian Crashing 4 年 2 个月 前 #990

  • tim
  • tim的头像
  • 离线
  • Moderator
  • 帖子: 226
  • 感谢您收到 30
  • 声望: 4
HI Sir,

I will do the same test as you did in my office, try more desktop and confirm what you said.
Once we build a stable GUI system on debian, i will build a dd image for you to clone the system.
本论坛禁止游客发帖。
创建页面时间:0.032秒